Wednesday, March 10, 2010

Mia_material texture hardware display problem

In Maya any duplicated a mia_material, mia_material_x or mia_material_x_passes, do not display the textures in the hardware display properly. You end up with a bunch of black objects.

You can run this script to fix the problem.

Download the script and copy the mel file in any script folder, call the command fixMiaHardwareShading() in the script editor to execute the script.

Enjoy textures in your 3d view once more!

14 comments:

  1. This comment has been removed by the author.

    ReplyDelete
  2. still have black material_x materials

    ReplyDelete
  3. I'll need to make sure this is compatible for 2011. I should be able to check this soon.

    ReplyDelete
  4. Thank you, worked fine on 2011 64.

    ReplyDelete
  5. very strange. i have maya 2011 x64 too, but still have black materials in viewport (mental ray materials) in high quality render

    ReplyDelete
  6. thx very much, it works well, I've been waiting for that for 3 years!

    ReplyDelete
  7. visit my blog, +18 0nly!!!!
    http://japan-porn-video.blogspot.com/

    ReplyDelete
  8. thank you so much! works wonders

    ReplyDelete
  9. Man, I've been looking for something like this forever. Thank you so much for your time and dedication in making this script! Works on maya 2011...

    ReplyDelete
  10. thx, it worked wonders! (maya 2011 x64)

    ReplyDelete
  11. i have search your blog from google its very informative.we have a list of medical transcription companies.i will revisite ur blog.

    ReplyDelete
  12. hun interesting blog.i really appreciate it,i have bookmark it for revisit. i have a list of rice exporters for online trade

    ReplyDelete

Note: Only a member of this blog may post a comment.